Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Login


Take the time to read our Privacy Policy.

202tonner Offline
#1 Posted : Sunday, 30 June 2019 5:05:06 PM(UTC)
202tonner

Rank: Newbie

Reputation:

Groups: Registered
Joined: 21/12/2018(UTC)
Posts: 6
Australia
Location: SA

Thanks: 1 times
The wipers on my HJ have always seemed a bit sluggish. Not surprising really, 4 decade old motor. But I had the plenum cover off recently and noticed that the sheet of metal where the passenger side wiper is mounted had been pushed down a bit. Also the mounting holes were a bit recessed downwards in the metal as well.
No doubt this is due to me and previous owners thumping them on with their hand. Oops.
A quick bit of tapping/levering/persuasion brought the metal back up to a flatter, normal looking level.
I refitted the arm and gave the wipers a go. Abracadabra! Much better. They were moving much more freely.

So if you are having a bit of trouble getting the wipers to work well it might be worth having a look at the mounting plates. In HJs, on the passenger side it is a bit of sheet metal with downturned edges. Easily pushed down. I reckon this was causing the arm to rest on the plenum cover when it was right down so giving a lot of resistance. Hope that helps.

Edited by user Sunday, 30 June 2019 6:04:45 PM(UTC)  | Reason: Not specified

Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2019, Yet Another Forum.NET
This page was generated in 0.127 seconds.