Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Login


Take the time to read our Privacy Policy.

laurence Offline
#1 Posted : Thursday, 30 September 2010 4:32:00 AM(UTC)
laurence

Rank: Member

Reputation:

Groups: Registered
Joined: 12/04/2006(UTC)
Posts: 113

Does anyone know about this Eurovox system 10 stacker in boot has problems, are they worth fixing or get new or second hand unit and are they security matched to head unit Whats the best way to fix this up Thanks
commodorenut Offline
#2 Posted : Thursday, 30 September 2010 5:40:00 AM(UTC)
commodorenut

Rank: Veteran

Reputation:

Groups: Moderator, Registered, Veteran
Joined: 2/03/2005(UTC)
Posts: 3,135

Thanks: 1 times
Was thanked: 35 time(s) in 33 post(s)
They aren't security matched - you can swap the stacker unit amongst any other VT/WH with a stacker, and even the VR/VS stackers (same stacker - just the writing on the lid is rotated 90 degrees).

They are a very, very, very common failure point in these cars. There are some reasonably easy fixes available, depending on the fault present.

If you can find a new one, buy a lotto ticket.... and going by the track record of myself, and numerous mates & relatives, almost all the working 2nd hand ones will fail within a few months of purchase.

There's basically no other stacker on the market anymore that will talk to the factory head unit. If you can get one of the older Sony models from the late 90s, they are almost identical in their compatibility - only the polarity of the data channels is transposed.

So that pretty much points back to fixing what you have. If you're not an electronics guru, then there's not a lot you can do, but start with the basic DIY things.

Sometimes they only need to be unplugged for about 10 seconds (at the unit) and plugged back in to reset them. holding the power button on the radio down for 5 seconds will also reset the communications link between them.

Other times the fault may be more permanent - I've had 2 VS ones lose their "dampers" and drop the guts inside the box. Fitting reasonable 2nd hand dampers from other failed units got one going, but it soon succumbed to other issues.

If you're getting the "E-99" error (it shows up on the radio's LCD screen) then Warren Turnbull has developed a good fix.

One of my mates has recently found a place in Sydney who do an exchange replacement with a warranty. It will be interesting to see how it goes. If it's all good, then I'll find out the details for you.


Cheers,

Mick
_______________________________________________________________

Judge a successful man not on how he treats his peers, but on how he treats those less fortunate.
Cheers,

Mick
_______________________________________________________________

Judge a successful man not on how he treats his peers, but on how he treats those less fortunate.
laurence Offline
#3 Posted : Thursday, 30 September 2010 4:45:03 PM(UTC)
laurence

Rank: Member

Reputation:

Groups: Registered
Joined: 12/04/2006(UTC)
Posts: 113

Thanks the problem was CD got stuck in unit we got it out but it was showing error 99 when it was in there know it just runs thru CDs but does not play them Please let me know about exchange units when you find out
Warren Turnbull Offline
#4 Posted : Monday, 4 October 2010 5:15:01 PM(UTC)
Warren Turnbull

Rank: Veteran

Reputation:

Groups: Registered, Veteran
Joined: 10/02/2009(UTC)
Posts: 2,343

Thanks: 2 times
Was thanked: 24 time(s) in 23 post(s)
I seem to have a bit more luck with these, I find that the white electronic grease dries out and stops the mechanism from operating. Have pulled them apart and added a bit of WD40 to the whitte grease and they are good again.

Mine has now been working for 4 years and the guy down the road over 12 months. The only other real problem is the laser, if this goes you can use the Sony laser if you can find one. As Mick said, they are hard to find these days as everyone is going MP3.

Warren

The best part about being wrong is the pleasure it brings to others.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2022, Yet Another Forum.NET
This page was generated in 0.074 seconds.